css28
Posts: 62
Joined: Fri Aug 02, 2019 2:14 pm
Delivery Date: 02 Aug 2019
Location: Bloomfield Twp, Michigan

Re: Dealership gives up on TCU, suggests I replace the unit?

Fri Feb 14, 2020 12:33 pm

Lothsahn wrote:
Thu Feb 13, 2020 12:33 pm
css28 wrote:
Thu Feb 13, 2020 10:45 am
I have a 2017 SV that I bought in August and the TCU has never worked for me.
On the menu screen there's a little icon of a gray car near the top with a diagonal red line through it. I worked over the phone with Customer Service and once they learned of the lined out car they said it had to be serviced by the dealer.

The nearest LEAF-capable dealer wants $176 for initial diagnosis, so it's not happening.
Isn't a 2017 still under warranty?
I doubt it--it has ~60k miles on it.
- Chris
----------
2017 SV, purchased 8/10/19, Coulis red

powersurge
Posts: 1742
Joined: Wed Oct 21, 2015 10:24 am
Delivery Date: 06 Dec 2014
Location: Long Island, NY

Re: Dealership gives up on TCU, suggests I replace the unit?

Fri Feb 14, 2020 1:01 pm

At 60 K miles, the car is out of warranty.

you bought it used, and this problem is just like another "as is" issue on a used car. Nissan is not responsible.

I would say... F____ it, and not even bother trying to fix something that has always given owners trouble.

The important thing is that the rest of the car is good.

css28
Posts: 62
Joined: Fri Aug 02, 2019 2:14 pm
Delivery Date: 02 Aug 2019
Location: Bloomfield Twp, Michigan

Re: Dealership gives up on TCU, suggests I replace the unit?

Fri Feb 14, 2020 3:46 pm

powersurge wrote:
Fri Feb 14, 2020 1:01 pm
At 60 K miles, the car is out of warranty.

you bought it used, and this problem is just like another "as is" issue on a used car. Nissan is not responsible.

I would say... F____ it, and not even bother trying to fix something that has always given owners trouble.

The important thing is that the rest of the car is good.
I'm good.
- Chris
----------
2017 SV, purchased 8/10/19, Coulis red

cthedan
Posts: 4
Joined: Wed Jan 08, 2020 10:12 am
Delivery Date: 08 Jan 2015
Leaf Number: 300104

Re: Dealership gives up on TCU, suggests I replace the unit?

Fri Mar 13, 2020 3:57 pm

Thank you so much everyone for your replies. I'd been impatiently checking for replies in the week after I first posted and kind of forgot. But look at all this help! Anyway, still won't work and like people suggest, probably not worth the $400.

The biggest drawback for me is not being able to precool the car in California. : ( :( : (

sdbmania
Posts: 133
Joined: Tue Jan 25, 2011 12:03 pm
Delivery Date: 23 May 2011
Leaf Number: 408285
Location: Southern California
Contact: Twitter

Re: Dealership gives up on TCU, suggests I replace the unit?

Sat Mar 14, 2020 9:57 pm

It sucks when the TCU doesn't work. In my case I was lucky, it just needed to be restarted, so I didn't have to pay to have it fixed. In the 2013 Leaf my mom has, I had the TCU upgraded and that was $200. I wouldn't pay more than that. So, you might as well wait a couple of years for when AT&T shuts off the 3G network. I'm sure we are all going to have to pay to upgrade the unit again if we still want to use the app.
2011 SL
Reserved: 6/21/2010
RAQ: 1/25/2011
Order accepted: 1/25/2011
Delivered: 5/10/2011

2013 SL, March

2013 SV Blue LEAF 1/25/17.

Now 2016 SL Black Leaf 2/4/20

Return to “General / Main Owners Forum”