BerryK
Posts: 3
Joined: Mon May 26, 2014 6:05 pm
Delivery Date: 25 May 2014

How to stop iPhone automatically playing when connected?

Fri May 30, 2014 11:10 am

Hi. I searched this section AND the Navigation owners manual without finding a solution.

When I connect my iPhone to a USB cable plugged into my 2014 LEAF, it starts playing music right away. If I'm ALREADY listening to the radio, this is very annoying.

Is there a way to disable this automatic switching of the audio source?

dm33
Posts: 676
Joined: Sat May 18, 2013 4:43 am
Delivery Date: 31 May 2013
Location: Raleigh, NC

Re: How to stop iPhone automatically playing when connected?

Fri May 30, 2014 11:42 am

BerryK wrote:Hi. I searched this section AND the Navigation owners manual without finding a solution.

When I connect my iPhone to a USB cable plugged into my 2014 LEAF, it starts playing music right away. If I'm ALREADY listening to the radio, this is very annoying.

Is there a way to disable this automatic switching of the audio source?

This is the single most annoying thing about the LEAF. Drives me crazy. The best solution I've come up with so far is to remove all music from my iPhone. It still tries to play it, stops anything else that was going on, but at least doesn't start playing all the time.

thankyouOB
Posts: 3577
Joined: Mon Feb 21, 2011 11:14 am
Delivery Date: 30 Apr 2011
Leaf Number: 1442
Location: Coastal LA

Re: How to stop iPhone automatically playing when connected?

Fri May 30, 2014 11:47 am

dm33 wrote:
BerryK wrote:Hi. I searched this section AND the Navigation owners manual without finding a solution.

When I connect my iPhone to a USB cable plugged into my 2014 LEAF, it starts playing music right away. If I'm ALREADY listening to the radio, this is very annoying.

Is there a way to disable this automatic switching of the audio source?

This is the single most annoying thing about the LEAF. Drives me crazy. The best solution I've come up with so far is to remove all music from my iPhone. It still tries to play it, stops anything else that was going on, but at least doesn't start playing all the time.
may reserve/delivery 4/30/11
--
ECOtality/LADWP/ Blink 4/4/11
--
Gardena Nissan, msrp -1k
red SL with etec L3
SOLAR POWERED since 2008

CmdrThor
Posts: 56
Joined: Fri Jun 21, 2013 5:41 am
Delivery Date: 07 Jun 2013
Location: Marietta, GA

Re: How to stop iPhone automatically playing when connected?

Fri May 30, 2014 11:50 am

dm33 wrote:This is the single most annoying thing about the LEAF. Drives me crazy. The best solution I've come up with so far is to remove all music from my iPhone. It still tries to play it, stops anything else that was going on, but at least doesn't start playing all the time.


Seems a little extreme. Are you plugging / unplugging iPhones in that much that you can't just switch the music back when you plug it in? If so you should probably get a cigarette lighter 12v USB charger and use that instead of the built in port.

dgalvan
Posts: 82
Joined: Mon Apr 28, 2014 8:46 am
Delivery Date: 25 Apr 2014
Location: Woodland Hills, CA (Los Angeles)

Re: How to stop iPhone automatically playing when connected?

Fri May 30, 2014 2:23 pm

I agree this is annoying. Would love a solution as well.
2014 Leaf S with Charger Package (Blue Ocean)
Purchased 4/25/2014, Totaled (hit from behind on freeway) 9/20/2016

2016 Leaf SV (Glacier White)
Purchased 9/30/2016

epirali
Posts: 581
Joined: Wed Oct 09, 2013 10:15 am
Delivery Date: 08 Oct 2013
Leaf Number: 418541
Location: Maryland

Re: How to stop iPhone automatically playing when connected?

Fri May 30, 2014 3:38 pm

dgalvan wrote:I agree this is annoying. Would love a solution as well.


Unfortunately most of my cars do the exact same thing, when you plug in iPhone/iPod they just switch and play...most alphabetically but one is totally random!

Sick of hearing the first 3-4 bars of "ABC" over and over and over again....

BerryK
Posts: 3
Joined: Mon May 26, 2014 6:05 pm
Delivery Date: 25 May 2014

Re: How to stop iPhone automatically playing when connected?

Mon Jun 02, 2014 4:40 pm

I asked at the dealership, and they didn't know how either. Oh well, if this is the most annoying thing about my new car, I figure I came out ahead!

BerryK
Posts: 3
Joined: Mon May 26, 2014 6:05 pm
Delivery Date: 25 May 2014

Re: How to stop iPhone automatically playing when connected?

Wed Jul 02, 2014 3:04 pm

Good news! I found that if I plug in the iPhone BEFORE "starting" the car, it doesn't auto-play.

cgaydos
Posts: 650
Joined: Thu Mar 07, 2013 6:36 pm
Delivery Date: 21 Nov 2012
Leaf Number: 009493025635
Location: Monument, Colorado

Re: How to stop iPhone automatically playing when connected?

Wed Jul 02, 2014 3:26 pm

epirali wrote:
dgalvan wrote:I agree this is annoying. Would love a solution as well.


Unfortunately most of my cars do the exact same thing, when you plug in iPhone/iPod they just switch and play...most alphabetically but one is totally random!

Sick of hearing the first 3-4 bars of "ABC" over and over and over again....


Probably better than hearing the start of "Abbey Road Documentary" every time I plug in the iPhone.
Red Leaf: 2012 SL, lease, acquired 21 November 2012
Blue Leaf: 2011 SL, purchase (new, was dealer demo), acquired 4 March 2013

seva
Posts: 4
Joined: Sun Feb 19, 2012 7:35 pm
Delivery Date: 04 Nov 2011
Leaf Number: 009625
Location: near the Great Smoky Mountains

Re: How to stop iPhone automatically playing when connected?

Tue Sep 09, 2014 9:38 am

BerryK wrote:Good news! I found that if I plug in the iPhone BEFORE "starting" the car, it doesn't auto-play.


i will certainly try this today. it's true that the iPhone will start to play the first song you ever loaded into your library, on ANY capable car, when connected via USB. THAT is something i want to kill apple for doing.

weirdly enough, if i'm on a bluetooth phone call and plug in my USB for charging, the song starts playing while on the phone call and WILL NOT STOP no matter what i do. the only option is to force-quit the app, which really doesn't keep my eyes on the road....

Return to “Music / Navigation / Handsfree”