TheSmith
Posts: 17
Joined: Fri Jun 05, 2015 4:16 am
Delivery Date: 27 Apr 2015

LEAF gen 1 CHAdeMO protocol conformance

Sun May 16, 2021 5:08 pm

Hi folks,

I was told by a good source working at a charger manufacturer that the Nissan LEAF gen 1 has CHAdeMO communication problems that are well documented. He did not want to elaborate more on that to protect their partnership for testing with car manufacturers, however.

So I'd like to know more. Does anyone know anything about that or know where I can find more information?

Regards,

Smith

knightmb
Posts: 951
Joined: Mon Jan 12, 2015 7:41 pm
Delivery Date: 26 Feb 2021
Leaf Number: 306291
Location: Franklin, TN

Re: LEAF gen 1 CHAdeMO protocol conformance

Sun May 16, 2021 6:08 pm

This forum is a good start. The most common problem is a vehicle fault that requires the Leaf to be seen by a dealership to reset the DTC code. Or for the rest of us, use LeafSpy to fix it. The QC at Nissan HQ still causes these vehicle faults on their modern chargers on the Gen 1 Leaf occasionally, I've had to use LeafSpy fix them for many random people I meet there. :lol:
2020 Leaf SL Plus - (Manufacture Date March 2020)
2013 Leaf SV (8 faithful years of service before trade in at 75,679 miles)

User avatar
SalisburySam
Posts: 385
Joined: Thu Sep 27, 2012 11:01 am
Delivery Date: 24 Feb 2012
Leaf Number: 018156
Location: Salisbury, NC

Re: LEAF gen 1 CHAdeMO protocol conformance

Tue May 18, 2021 4:22 am

I’ve only used the CHAdeMO port in my 2012 SL a very few times at the local Nissan dealer. It worked flawlessly each time…no issue whatever.
Nissan 2012 LEAF SL, 13,600 miles, 9 bars, 35-mile range

Tesla Model 3: Long Range Rear Wheel Drive | Extended AutoPilot | Full Self-Driving | HW3 Upgrade
Delivered: July, 2018 | 17,000 miles | PM me for Tesla referral code

User avatar
Nubo
Posts: 5978
Joined: Fri May 28, 2010 11:01 am
Delivery Date: 31 Oct 2014
Location: Vallejo, CA

Re: LEAF gen 1 CHAdeMO protocol conformance

Tue May 18, 2021 10:28 am

I seem to recall there were some chademo stations that wouldn't work with Leaf at some point; with finger-pointing over which party was or wasn't responsible, but I don't recall what the root cause was.
I noticed you're still working with polymers.

User avatar
Dala
Posts: 337
Joined: Sun Oct 28, 2018 11:24 am
Delivery Date: 01 Jan 2015
Leaf Number: 316851
Location: Finland
Contact: Website

Re: LEAF gen 1 CHAdeMO protocol conformance

Wed May 19, 2021 12:45 am

The Gen1 ZE0 2011-2012 LEAF is only Chademo v0.9 compatible. This means that it doesn't send out the SOC% value to the station, so the station needs to calculate the SOC% based on the kWh full and kWh current values.

The Gen2 AZE0 2013-2017 is Chademo v1.0 compatible and sends SOC% on the QC-bus

Maybe this was what the protocol conformance issue was?

User avatar
JeremyW
Posts: 1563
Joined: Sun Nov 13, 2011 12:53 am
Delivery Date: 23 Jun 2012
Leaf Number: 19136
Location: San Gabriel, CA

Re: LEAF gen 1 CHAdeMO protocol conformance

Wed May 19, 2021 8:50 pm

The 2011 and 2012 Leafs have an incorrect calculation for remaining time to full, which is displayed by some chargers. I believe it always counts down from 254 minutes. That particular problem is mostly harmless, however.
Former 2012 SL leasee (6/23/12 - 9/23/15)
Former Honda Fit EV leasee
Former Chevy Spark EV owner
Now driving Tesla Model 3

TheSmith
Posts: 17
Joined: Fri Jun 05, 2015 4:16 am
Delivery Date: 27 Apr 2015

Re: LEAF gen 1 CHAdeMO protocol conformance

Sun May 30, 2021 2:20 pm

Thanks for the information. I've got many charging problems over the last two years with my 2015 LEAF. I cannot tell myself where the bugs are, but your input is interesting nonetheless.

Smith

User avatar
JeremyW
Posts: 1563
Joined: Sun Nov 13, 2011 12:53 am
Delivery Date: 23 Jun 2012
Leaf Number: 19136
Location: San Gabriel, CA

Re: LEAF gen 1 CHAdeMO protocol conformance

Mon May 31, 2021 11:43 am

A 2015 Leaf will follow the CHAdeMO spec pretty much to a T. Compatibility between a given station and vehicle is not usually an issue these days, and CHAdeMO itself is pretty simple compared to the monstrosity that is CCS.

I suspect the issue is either with your vehicle itself (not leafs in general), a particular troubled charging station, or the connector on said charging station. Can you say where you've had trouble? Brand, location, and charger manufacturer would be helpful.
Former 2012 SL leasee (6/23/12 - 9/23/15)
Former Honda Fit EV leasee
Former Chevy Spark EV owner
Now driving Tesla Model 3

Return to “Batteries & Charging”