gillmj24
Posts: 38
Joined: Wed Jun 19, 2019 2:27 pm
Delivery Date: 28 Dec 2020

Rain-X de-icer for propilot front camera

Tue Jan 19, 2021 7:56 pm

Bought some of this in an orange bottle with some of my Advance Auto rewards dollars.

It's been frosty in the mornings lately, and fog on the inside of the windshield. I have been pre-heating the car while plugged in before I leave in the morning, but the camera looking front is sealed off, so it only heats up via conduction of the warmed glass, not warm air of the cabin hitting it directly. I didn't notice until after a few miles, I got a sudden yellow flashing lane warning alert, vibrating steering wheel, and one of the 2 collision warning lights lit up (presumably the front one, they're too similar IMHO). It was still frosty/foggy on the outside of the windshield there when I got to where I was going, but I rubbed it dry with my glove so for the trip home there were no warnings after I restarted the car.

The next day I tried my de-icer spray and that prevented any such errors. I suppose the car's windshield washer fluid will hit this part of the windshield too....

LeftieBiker
Moderator
Posts: 16934
Joined: Wed May 22, 2013 3:17 am
Delivery Date: 30 Apr 2018
Location: Upstate New York, US

Re: Rain-X de-icer for propilot front camera

Tue Jan 19, 2021 8:27 pm

Good tip! I'm going to leave this topic up for a while, then add it to the Gen II Tips & Tricks topic.
Brilliant Silver 2021 Leaf SV40 W/ Pro Pilot & Protection
2009 Vectrix VX-1 W/18 Leaf modules, & 2 lithium E-bicycles.
BAFX OBDII Dongle
PLEASE don't PM me with Leaf questions. Just post in the topic that seems most appropriate.

gillmj24
Posts: 38
Joined: Wed Jun 19, 2019 2:27 pm
Delivery Date: 28 Dec 2020

Re: Rain-X de-icer for propilot front camera

Mon Feb 08, 2021 7:11 am

So this morning right before arriving at work, I got a similar error, but this time "Camera Temperature Too High".

It was no more than 75F inside, and outside was 15F when I started and 23F when I got to work.

Again, turning car off and back on after I was parked, the error did not reappear.

GerryAZ
Gold Member
Posts: 2954
Joined: Mon Nov 22, 2010 6:47 pm
Delivery Date: 12 Jun 2011
Location: Phoenix, AZ

Re: Rain-X de-icer for propilot front camera

Mon Feb 08, 2021 7:09 pm

Even if you had full defrost function with cabin temperature setpoint rather high, it should not get the camera hot enough to cause issues so I suspect you have something going on with the camera.
Gerry
Silver LEAF 2011 SL rear ended (totaled) by in-attentive driver 1/4/2015 at 50,422 miles
Silver LEAF 2015 SL purchased 2/7/2015; traded 8/10/2019 at 82,436 miles
White LEAF 2019 SL Plus purchased 8/10/2019

gillmj24
Posts: 38
Joined: Wed Jun 19, 2019 2:27 pm
Delivery Date: 28 Dec 2020

Re: Rain-X de-icer for propilot front camera

Mon Feb 08, 2021 7:50 pm

Me too. I was surprised. This seems like the kind of thing the dealer will not replicate and if they gave me a loaner it would be a Sentra which I don't need.

Just passed 1000 miles this weekend.

GerryAZ
Gold Member
Posts: 2954
Joined: Mon Nov 22, 2010 6:47 pm
Delivery Date: 12 Jun 2011
Location: Phoenix, AZ

Re: Rain-X de-icer for propilot front camera

Mon Feb 08, 2021 9:25 pm

You have 3 years, 36,000 miles of full warranty coverage so let it go (document every pro pilot glitch in a log book for future reference) until it gets worse. Enjoy your new car.
Gerry
Silver LEAF 2011 SL rear ended (totaled) by in-attentive driver 1/4/2015 at 50,422 miles
Silver LEAF 2015 SL purchased 2/7/2015; traded 8/10/2019 at 82,436 miles
White LEAF 2019 SL Plus purchased 8/10/2019

dllsboy93
Posts: 1
Joined: Tue Mar 16, 2021 4:51 pm
Delivery Date: 16 Mar 2021
Leaf Number: 303816

Re: Rain-X de-icer for propilot front camera

Tue Mar 16, 2021 5:20 pm

Hello,

I have had my Nissan leaf SL Plus for over 30 days. They flashing light started on day 3. First drive to work. It turned off my Pro Pilot while I was going 60+MPH in 60 degree weather. The light has been off and on leaving no error message.

My car as been in back to the dealer 2 times with multiple pictures and videos, the dealer has not been able to recreate the light. No frost or debris on the front end of the car.

Attached is a link to my Google photos. https://photos.app.goo.gl/xbowKih7Cfq8D8Dr5

Return to “Tips & Tricks”