cthedan
Posts: 4
Joined: Wed Jan 08, 2020 10:12 am
Delivery Date: 08 Jan 2015
Leaf Number: 300104

Bafx does not work, possible connection to ongoing TCU problems?

Sat Mar 14, 2020 2:02 pm

Hi all, this is possibly related to my first post here: viewtopic.php?f=27&t=30883

So when I first bought this used 2016 Leaf a few months back, I used Leafspy and a janky "FixIt" OBD scanner before buying and it worked.

This setup continued to work until I brought it in to the dealership for standard maintenance, but at the time, no TCU work was performed. But when I got the car back, Leafspy would not connect, other ODB scanners wouldn't work or light up. There were seemingly random instances where the lights would flash but still no Leafspy success.

When I asked the dealership, they told me that they found a lot of error codes using their Nissan-approved scanner and that I shouldn't use 3rd party scanners. Of course they said I could not get my hands on a Nissan scanner, so I was out of luck. 0_0. Basically told me I couldn't use the OBD port anymore.

I did some research here about the recommended Bafx scanner, plugged that in, it lit up, but Leafspy again could not connect. Hasn't lit up since. Any advice would be appreciated, thanks all! As you can imagine, I can accept no TCU. But no Leafspy on top of that?!

LeftieBiker
Moderator
Posts: 14633
Joined: Wed May 22, 2013 3:17 am
Delivery Date: 30 Apr 2018
Location: Upstate New York, US

Re: Bafx does not work, possible connection to ongoing TCU problems?

Sat Mar 14, 2020 3:11 pm

Do the units that wouldn't light up flicker if you wiggle them in the port? Those ports are easily damaged, and I suspect that the dealership may have damaged yours.
Scarlet Ember 2018 Leaf SL W/ Pro Pilot
2009 Vectrix VX-1 W/18 Leaf modules, & 3 EZIP E-bicycles.
BAFX OBDII Dongle
PLEASE don't PM me with Leaf questions. Just post in the topic that seems most appropriate.

cthedan
Posts: 4
Joined: Wed Jan 08, 2020 10:12 am
Delivery Date: 08 Jan 2015
Leaf Number: 300104

Re: Bafx does not work, possible connection to ongoing TCU problems?

Wed Mar 18, 2020 11:45 am

Leftie, thank you for gracing my thread with your presence. I will give it a good wiggle and see what happens. If the dealership broke it, I guess I'm effed though! Thanks again.

LeftieBiker
Moderator
Posts: 14633
Joined: Wed May 22, 2013 3:17 am
Delivery Date: 30 Apr 2018
Location: Upstate New York, US

Re: Bafx does not work, possible connection to ongoing TCU problems?

Wed Mar 18, 2020 12:46 pm

It shouldn't be hard for a dealer to replace the port. The tough part is getting them to admit that they broke it. If you haven't already, don't mention that you've used LeafSpy before.
Scarlet Ember 2018 Leaf SL W/ Pro Pilot
2009 Vectrix VX-1 W/18 Leaf modules, & 3 EZIP E-bicycles.
BAFX OBDII Dongle
PLEASE don't PM me with Leaf questions. Just post in the topic that seems most appropriate.

DaveinOlyWA
Posts: 14690
Joined: Sat Apr 24, 2010 7:43 pm
Delivery Date: 16 Nov 2019
Leaf Number: 319862
Location: Olympia, WA
Contact: Website

Re: Bafx does not work, possible connection to ongoing TCU problems?

Sat Mar 21, 2020 9:10 am

The port not working should never be an issue. It is REQUIRED for a maintenance shop to do a lot of diagnostics. I wouldn't use Bafx as they have had issues in the past with other OBD devices. Spend the money, get the recommended device. If that doesn't work, take it back and insist they fix the port.

FYI; I NEVER leave my scanner in the port when taking it to the dealership. As far as the port being fragile? That is something I have yet to see.
2011 SL; 44,598 mi, 87% SOH. 2013 S; 44,840 mi, 91% SOH. 2016 S30; 29,413 mi, 99% SOH. 2018 S; 25,185 mi, SOH 92.23%. 2019 S Plus; 7059.6 mi, 95.35% SOH
My Blog; http://daveinolywa.blogspot.com" onclick="window.open(this.href);return false;

GerryAZ
Gold Member
Posts: 2434
Joined: Mon Nov 22, 2010 6:47 pm
Delivery Date: 12 Jun 2011
Location: Phoenix, AZ

Re: Bafx does not work, possible connection to ongoing TCU problems?

Sat Mar 21, 2020 10:32 am

I had an OBDII port damaged by a dealer (connector was loose after dealer service), but was still able to use my scanner by carefully holding the connection while scanning. I suspect the dealer damaged the connector and a lot of the error codes they found were due to the loose connection. It may be possible to replace the connector.

I recommend that nothing be left plugged in to the port when taking a vehicle to a dealer or other service facility.
Gerry
Silver LEAF 2011 SL rear ended (totaled) by in-attentive driver 1/4/2015 at 50,422 miles
Silver LEAF 2015 SL purchased 2/7/2015; traded 8/10/2019 at 82,436 miles
White LEAF 2019 SL Plus purchased 8/10/2019

LeftieBiker
Moderator
Posts: 14633
Joined: Wed May 22, 2013 3:17 am
Delivery Date: 30 Apr 2018
Location: Upstate New York, US

Re: Bafx does not work, possible connection to ongoing TCU problems?

Sat Mar 21, 2020 1:32 pm

DaveinOlyWA wrote:
Sat Mar 21, 2020 9:10 am
The port not working should never be an issue. It is REQUIRED for a maintenance shop to do a lot of diagnostics. I wouldn't use Bafx as they have had issues in the past with other OBD devices. Spend the money, get the recommended device. If that doesn't work, take it back and insist they fix the port.

FYI; I NEVER leave my scanner in the port when taking it to the dealership. As far as the port being fragile? That is something I have yet to see.

Can you elaborate on BAFX scanner having issues? I have had no trouble with mine, having used it on 3 vehicles now (one with an already damaged port that others failed to scan). As for the ports being fragile, it's been reported here on the previous Leafs, and the new Leaf uses the same unit in the same location. It isn't a common enough issue that we're all going to personally "see" it, in part because most people don't use that port.
Scarlet Ember 2018 Leaf SL W/ Pro Pilot
2009 Vectrix VX-1 W/18 Leaf modules, & 3 EZIP E-bicycles.
BAFX OBDII Dongle
PLEASE don't PM me with Leaf questions. Just post in the topic that seems most appropriate.

User avatar
Dala
Forum Supporter
Posts: 194
Joined: Sun Oct 28, 2018 11:24 am
Delivery Date: 01 Jan 2015
Leaf Number: 316851
Location: Finland
Contact: Website

Re: Bafx does not work, possible connection to ongoing TCU problems?

Sat Mar 21, 2020 2:07 pm

Use a multimeter;
Check GND (4 / 5), check constant +12V (16), check switched 12V (8), check resistance between CAR-CAN H/L (60Ohm 6 / 14) and EV-CAN H/L (60Ohm 12 / 13)

Image

That way you can see what is damaged.

Return to “General / Main Owners Forum”