User avatar
Posts: 348
Joined: Thu Aug 19, 2010 8:35 am
Delivery Date: 21 Apr 2011
Leaf Number: 1009
Contact: Website

GE Wattstation Connect Problems

GE rolled out its EVSE network Wattstation Connect in late April, 2012. I started an account there early on to check out the features.

In December, I got interested in using the newly installed Wattstations at the Irvine Spectrum. So I splurged $3.49 + shipping and tax for a Wattstation Connect card (Amazon)

I've had a lot of problems with their system since then (link link) so I think it might be useful to list them in their own thread and track GE's progress fixing them. I have been working with the GE reps since late December, and I'm hearing from them weekly, but progress has been glacial and more problems are being exposed as we go along.

Problem List

Setup of link to Paypal fails
When logged into your Wattstation Connect account (Settings | My Payment Information), you click on the Set Up Account button. You're sent to Paypal to authenticate. Then when you're done at Paypal, you click a button which is supposed to take you back to your Wattstation account. However, it dumps you off at the Wattstation Connect login page as if you were never logged in. The Paypal link remains unset.
After repeated attempts, I tried doing a password reset on my account (hoping this would reset something). At the same time, GE backend support was doing some fixes. Something made this finally work, but only after I logged into Wattstation Connect, tried setting up the Paypal link, failed, then logged back in and tried again. So I'd say this is not reliable, but you can get it to work if persistent. My account is now linked.

You can verify Paypal is linked correctly:
Wattstation Connect
Settings | My Payment Information
button will read "Remove Account"

My Account | Profile | My Money | My preapproved payments (Update)
GE will be listed with a status of "Active"

After swiping the card at the Wattstation, you get a scary email from Paypal
Shortly after swiping and starting my charge, I got an email from Paypal titled

Code: Select all

You have authorized a payment to The Irvine Company LLC
The email stated that I was paying $16. So this is just a pre-authorization, right? But nowhere in the Paypal email does it say that. It just looks like an order confirmation. This will be a customer support issue. Want to play around? Swipe all the stations with your card, and you'll get a bunch of authorization emails. On second thought, read the rest of this post before you do that..
No progress

The preauthorization charge does not go away
GE says these charges should go away "within a couple of hours", but I have one that has remained in my Paypal account for a week. This may be because I authorized at a station, but didn't plug in. Or it could be because GE is not voiding/cancelling the preauthorization transaction properly.
No progress. Reported to GE technical support.

Wattstation Connect reports duplicate charging sessions
In Wattstation Connect, under Reports, you can Generate a list of Charging Transactions. I'm currently seeing two sessions of the same duration (40:58) and charge ($1.33). Everything is identical except for the times. Looks like the system got confused and logged the session once at the beginning and another time at the end, or got confused by my swipe of a second Wattstation, and assumed I had charged there as well. :roll: Luckily, this is only a reporting problem, and I only got charged once in Paypal.
No progress. Reported to GE technical support.
2011 Nissan LEAF, Glacier White, SL-QC, Reserved: 4/20/10, Ordered: 9/2/10, Delivered: 4/21/11, 33,000+ miles, 12 bars, EVSEUpgrade Rev1
1997 S10 Electric Truck (converted to NiMH by EV Bones)
1981 Jet Electrica (sold '06)
Plug In America

Return to “EVSE / Charging Equipment and Networks”