RonSwanson
Forum Supporter
Posts: 60
Joined: Fri Apr 07, 2017 1:13 pm

Getting pics to show up in a posting

Fri Feb 28, 2020 8:49 am

I paid to become a forum supporter to post a for sale ad: viewtopic.php?f=41&t=30951

I tried to post my imgur links as embedded pics but they just showed up as broken pics so now I Just have links. I literally just would do the [img] tags before and after the links.

How can I have it so my pics show up in my post?

User avatar
wxxyz
Posts: 455
Joined: Mon Aug 03, 2009 10:08 pm

Re: Getting pics to show up in a posting

Fri Feb 28, 2020 9:21 am

Hi Ron,

As a forum supporter you can upload the image to your post (by using the 'attachments' tab).

If you want to link from Imgur, you need the image URL, not the URL of the page it is on, but I don't think Imgur allows that (and that could be why you see the broken image in your post)

RonSwanson
Forum Supporter
Posts: 60
Joined: Fri Apr 07, 2017 1:13 pm

Re: Getting pics to show up in a posting

Fri Feb 28, 2020 10:01 am

wxxyz wrote:
Fri Feb 28, 2020 9:21 am
Hi Ron,

As a forum supporter you can upload the image to your post (by using the 'attachments' tab).

If you want to link from Imgur, you need the image URL, not the URL of the page it is on, but I don't think Imgur allows that (and that could be why you see the broken image in your post)
Thanks for the info!

I'm not seeing an attachments tab when I create/edit a post.

User avatar
jlv
Moderator
Posts: 1317
Joined: Thu Apr 24, 2014 6:08 pm
Delivery Date: 30 Apr 2014
Leaf Number: 424487
Location: Massachusetts

Re: Getting pics to show up in a posting

Fri Feb 28, 2020 11:13 am

RonSwanson wrote:
Fri Feb 28, 2020 10:01 am
I'm not seeing an attachments tab when I create/edit a post.
Right under the "Save Draft" "Preview" "Submit" buttons should be an area with 2 tabs, "Options" and "Attachments".
Capture.PNG
After you attach an image, it will give you an option to place it in-line.
You do not have the required permissions to view the files attached to this post.
LEAF '13 SL+Prem (mfg 12/13, leased 4/14, bought 5/17, sold 11/18) 34K mi, AHr 58, SOH 87%
Tesla S 75D (3/17)
Tesla X 100D (12/18)
93K 100% BEV miles since '14
ICE free since '18

User avatar
jlv
Moderator
Posts: 1317
Joined: Thu Apr 24, 2014 6:08 pm
Delivery Date: 30 Apr 2014
Leaf Number: 424487
Location: Massachusetts

Re: Getting pics to show up in a posting

Fri Feb 28, 2020 11:17 am

wxxyz wrote:
Fri Feb 28, 2020 9:21 am
If you want to link from Imgur, you need the image URL, not the URL of the page it is on, but I don't think Imgur allows that (and that could be why you see the broken image in your post)
imgur does allow that. When you add an image there, the default option they give you is the link to their page, but they'll also provide you with the direct image URL that you can use in an IMG tag.

E.g., for their first picture from their for-sale post

Code: Select all

https://imgur.com/LkxvCYM
the image is

Code: Select all

https://i.imgur.com/LkxvCYM.jpg
which looks like this in an IMG tag:
Image
LEAF '13 SL+Prem (mfg 12/13, leased 4/14, bought 5/17, sold 11/18) 34K mi, AHr 58, SOH 87%
Tesla S 75D (3/17)
Tesla X 100D (12/18)
93K 100% BEV miles since '14
ICE free since '18

RonSwanson
Forum Supporter
Posts: 60
Joined: Fri Apr 07, 2017 1:13 pm

Re: Getting pics to show up in a posting

Fri Feb 28, 2020 12:42 pm

jlv wrote:
Fri Feb 28, 2020 11:13 am
Right under the "Save Draft" "Preview" "Submit" buttons should be an area with 2 tabs, "Options" and "Attachments".Capture.PNG
After you attach an image, it will give you an option to place it in-line.
Yeah I don't have that tab for attachments. :(
jlv wrote:
Fri Feb 28, 2020 11:17 am
imgur does allow that. When you add an image there, the default option they give you is the link to their page, but they'll also provide you with the direct image URL that you can use in an IMG tag.

E.g., for their first picture from their for-sale post

Code: Select all

https://imgur.com/LkxvCYM
the image is

Code: Select all

https://i.imgur.com/LkxvCYM.jpg
which looks like this in an IMG tag:
Image
Excellent! This worked. Thank you.

User avatar
jlv
Moderator
Posts: 1317
Joined: Thu Apr 24, 2014 6:08 pm
Delivery Date: 30 Apr 2014
Leaf Number: 424487
Location: Massachusetts

Re: Getting pics to show up in a posting

Fri Feb 28, 2020 1:03 pm

RonSwanson wrote:
Fri Feb 28, 2020 12:42 pm
Yeah I don't have that tab for attachments. :(
wxxyz wrote:
Fri Feb 28, 2020 9:21 am
As a forum supporter you can upload the image to your post (by using the 'attachments' tab).
As wxxyz says, you should have it, especially since the forum sees you are a supporter. I'll have to pass it to wxxyz to figure out what's wrong.
LEAF '13 SL+Prem (mfg 12/13, leased 4/14, bought 5/17, sold 11/18) 34K mi, AHr 58, SOH 87%
Tesla S 75D (3/17)
Tesla X 100D (12/18)
93K 100% BEV miles since '14
ICE free since '18

Plugg
Posts: 25
Joined: Sat Jul 27, 2013 4:56 pm
Delivery Date: 16 May 2013
Location: Seattle, WA

Re: Getting pics to show up in a posting

Mon Mar 02, 2020 8:40 pm

I just renewed my status as a supporter, logged out and back in, but I don't seem to have an attachment tab either. Any assistance appreciated! :)

User avatar
jlv
Moderator
Posts: 1317
Joined: Thu Apr 24, 2014 6:08 pm
Delivery Date: 30 Apr 2014
Leaf Number: 424487
Location: Massachusetts

Re: Getting pics to show up in a posting

Tue Mar 03, 2020 7:30 am

Plugg wrote:
Mon Mar 02, 2020 8:40 pm
I just renewed my status as a supporter, logged out and back in, but I don't seem to have an attachment tab either. Any assistance appreciated! :)
Your user account doesn't show up as a "Forum Supporter", so you're not tagged as such yet. I suggest sending a PM to wxxyz.
LEAF '13 SL+Prem (mfg 12/13, leased 4/14, bought 5/17, sold 11/18) 34K mi, AHr 58, SOH 87%
Tesla S 75D (3/17)
Tesla X 100D (12/18)
93K 100% BEV miles since '14
ICE free since '18

Plugg
Posts: 25
Joined: Sat Jul 27, 2013 4:56 pm
Delivery Date: 16 May 2013
Location: Seattle, WA

Re: Getting pics to show up in a posting

Tue Mar 03, 2020 10:22 am

Thanks - I'll do so. I have the receipt from paypal showing acceptance of payment.

Return to “Website/Forum Discussions”