It is currently Wed Oct 22, 2014 11:36 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 75 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
Author Message
PostPosted: Fri Apr 15, 2011 8:10 am 
Offline

Joined: Tue Oct 19, 2010 3:22 pm
Posts: 583
Location: San Marcos, CA
Delivery Date: 20 Apr 2011
Leaf Number: 1290
Randy wrote:
Nissan / Clarion really need to produce a software update that respects the track number tags and plays them in order that way....


It's not just Nissan / Clarion. I have the same issue in my home with DirecTV and PS3. I have NAS (Network Attached Storage) with all my music on it. The UI on these devices ignores the track #. I've have to add the track# to the name. I think the programmers have never listen to an entire album. They are from the iPod shuffle generation. It's a real PIA especially when the track numbers are significant e.g. Side II of Abbey Road or The Who's Tommy.

_________________
Leaf eTec Blue Ocean
Reserved 6/25/10
EVProject approved 1/06/11
Blink EVSE Installed 4/6/11 (Separate meter, ethernet connection)
Ordered 1/25/11 Delivered 4/20/2011


Top
 Profile  
 
PostPosted: Fri Apr 15, 2011 8:19 am 
Offline
Moderator

Joined: Thu Apr 22, 2010 11:41 am
Posts: 10571
Location: Seattle, WA
Delivery Date: 25 Feb 2011
Leaf Number: 303
jcesare wrote:
I think the programmers have never listen to an entire album. They are from the iPod shuffle generation.

Well, then the problem is that they are letting the programmers decide how it should work.

I don't remember playing through XBox 360 - but my guess is ut uses Zune and will play by track # (or shuffle etc).

_________________
1st Leaf : 2/28/2011 to 5/6/2013
2nd Leaf : 5/4/2013 to ?


Top
 Profile  
 
PostPosted: Sat Jun 04, 2011 11:48 am 
Offline

Joined: Tue Jan 04, 2011 2:46 pm
Posts: 319
Delivery Date: 18 May 2011
Leaf Number: 1823
turbo2ltr wrote:
much to my dismay, is that if I skip a track with the steering wheel controls while in the shuffle all mode, it skips to the next track in the folder that contains the currently playing song, not the next random song. I consider this a bug.
I just found this too and I agree that it is a bug.

I just had the Leaf mess up my flash drive. I pulled it out mid-song (USB is fully hot pluggable), then when I put it in the computer, it said the drive needed to be formatted. :cry:

There goes the hours I spent selecting what music to put on the drive for my driving music.

_________________
~Pat
SLe VIN 1823 reserved 4/20/10, ordered 10/22/10, delivered May 18th 2011
1998 Chevy S10EV (Feb 2007 - May 8th 2011)
4kW Solar PV system 2007
Oregon Electric Vehicle Association
Occasional PlugInCars.com writer
Occasional WhatDrive.us panelist
Cars with Cords blogger


Top
 Profile  
 
PostPosted: Sun Jun 05, 2011 9:52 pm 
Offline

Joined: Sun Apr 25, 2010 7:47 pm
Posts: 841
Location: Silicon Valley
Delivery Date: 08 Sep 2011
Most of my music on my flash drive was in .wav format. I spent all afternoon reformatting it in WMA. I will make sure to save a copy on my hard drive so that if it gets messed up by the Leaf I can just copy it all back again.

_________________
OnWords


Top
 Profile  
 
PostPosted: Sat Jan 07, 2012 10:03 pm 
Offline

Joined: Mon Nov 28, 2011 12:34 am
Posts: 153
Location: Gilbert/Chandler Arizona
Delivery Date: 21 Dec 2011
Leaf Number: 15143
evnow wrote:
All this means that Leaf doesn't use the media portion of Windows Automotive. May be they will have time to incorporate that in MY2012.


It seems not.

In my 2012, USB operation appears to be identical to what I've seen described earlier in this thread. There is no shuffle (a future feature I'm sure, rather than a bug), and apparently no use of MP3 metadata.

I've organized a 512MB thumb drive into
root > artist > album > song and
root > podcast > episode

This works well enough, but since metadata is not used, there is no indication of how long a track might be. For podcasts, a "song" is often >30 minutes. There doesn't seem to be a way to fast-forward or back-up within a song. Another future feature for a very stupid player I'm afraid.

When I plugged my android phone into the USB port, I was expecting only to be able to charge the battery, but I got more. The file structure containing MP3s was read out and displayed/played just like the thumbdrive.

_________________
1st Batt Bar @ 8.5k mi. 29Aug2012
2nd Batt Bar @18.2k mi. 14Jun2013
3rd Batt Bar @(21k) mi. Aug2013
4th Bar @ 34.0k Oct 5, 2014
SOH=63, Hx=42.39 AHr=41.77 Blue 2012 SL, 3 Yr Lease ends Dec2014


Top
 Profile  
 
PostPosted: Sat Jan 07, 2012 10:07 pm 
Offline

Joined: Mon Nov 28, 2011 12:34 am
Posts: 153
Location: Gilbert/Chandler Arizona
Delivery Date: 21 Dec 2011
Leaf Number: 15143
garygid wrote:
What brand, model, and size, please?

I believe any 2.5 inch drive would work. It seems they were intended to be powered only by USB.

_________________
1st Batt Bar @ 8.5k mi. 29Aug2012
2nd Batt Bar @18.2k mi. 14Jun2013
3rd Batt Bar @(21k) mi. Aug2013
4th Bar @ 34.0k Oct 5, 2014
SOH=63, Hx=42.39 AHr=41.77 Blue 2012 SL, 3 Yr Lease ends Dec2014


Top
 Profile  
 
PostPosted: Sat Jan 07, 2012 10:18 pm 
Offline

Joined: Mon Nov 28, 2011 12:34 am
Posts: 153
Location: Gilbert/Chandler Arizona
Delivery Date: 21 Dec 2011
Leaf Number: 15143
blorg wrote:
Has anyone really identified the play order that it does by default on a USB drive? Manual says that it plays in the order that the files were put onto the drive, but I'm seeing it playing by file name order. I'm not sure if that's just how my software ended up copying it, so it happens to be the same either way or not.

The files seem to be played in alpha-numeric filename order. But then, I wrote the entire album to the thumb drive in one shot. Albums were written out of order, but are displayed/played in foldername order.

I got in the habit long ago to precede song names with 2-digit track numbers for this very reason.

Quote:
What are other people doing to work around this, other than going the ipod route?

I don't think a workaround is possible. Everything I've seen suggests the filestructure dictates playback order.

_________________
1st Batt Bar @ 8.5k mi. 29Aug2012
2nd Batt Bar @18.2k mi. 14Jun2013
3rd Batt Bar @(21k) mi. Aug2013
4th Bar @ 34.0k Oct 5, 2014
SOH=63, Hx=42.39 AHr=41.77 Blue 2012 SL, 3 Yr Lease ends Dec2014


Top
 Profile  
 
PostPosted: Thu Jan 12, 2012 4:22 pm 
Offline

Joined: Sun Apr 25, 2010 7:47 pm
Posts: 841
Location: Silicon Valley
Delivery Date: 08 Sep 2011
After seven months of ownership I now have a different perspective on this. First, the shuffle feature works just fine, although, as noted, if you flip the lever on the steering wheel to the next song, it's always the next one in the same folder. I have found that it does skip to each of my three folders randomly. It seemed to skip randomly from song to song also, but now I don't think it does. I've found that there are many songs that are played quite often and some, in fact a large block of cuts, that have never been played.

Early in this thread it was stated that the USB drive had a limit of 510 files. According to the spec chart on p. 4-8 of the navigation system manual the CD has this limit but the USB can go to 8000 files, as long as each folder does not exceed 255 files. Mine all have < 255 files, yet the first folder I put on the drive, Rock, seems to play all the songs randomly, the second folder (miscellaneous) does fairly well but misses some, and the last, Folk & Classical, plays a very limited selection of songs, or so it seems. It is as though the file system grabs all of the songs from the first folder, and some from the next 2, but stops after a limited number and only plays those, rather than going back onto the USB drive and randomly choosing from all ~220 songs in a particular folder. Of course I haven't done a scientific controlled study to verify my impression, but I was wondering if others have experienced this? Any theories or recommendations on how to get it to play the whole range (without having to play 10-20 string quartets in a row)?

_________________
OnWords


Top
 Profile  
 
PostPosted: Fri Jan 13, 2012 5:20 pm 
Offline
Gold Member
User avatar

Joined: Thu Jul 28, 2011 8:12 am
Posts: 382
Location: Brentwood, TN
Delivery Date: 15 Nov 2011
Leaf Number: 1567
I use a 4GB thumb drive. I've already filtered all of my music files (wav, mp3, ogg, flac) using EasyTag, a compilation and general purpose swiss knife application which runs on Linux. Then I take the 3500+ music files and shotgun them into the stick drive using Brasero, another Linux all-purpose audio player which I can have randomize tracks. I've got about 225 hours that way.

The left hand pickle shift on the wheel take some practice since in my case I have gone from stick drive to bluetooth to Sirus and there are 3 Sirus folders each with a number of "stations" inside of each; then on to the FM and AM radio in a big circle. It has only been in the last few days that I discovered pressing the pickle at the same time as pulling or pushing it.

The screen display is OK, I suppose, but I am always hitting the mode button. The titles and artists are a PITA, but after re-writing the thunb drive a couple of times I got it set to the correct sequence.

I would like to be able to have a meta-pickle or something to trigger a paradigm shift between Insane Clown Posse tracks and Verdi's Operas.

Dave

_________________
Ira est potens et pertinax.
Study History - Know the Future
N4CVX; ex-VP2EHF; ex-DA1BB; ex-KR6DEM
2012 SL Glacier Pearl VIN: 1567
Go to www.aprs.fi and search for n4cvx-9 to see my tracks in real time.


Top
 Profile  
 
PostPosted: Fri Feb 03, 2012 11:06 am 
Offline

Joined: Mon Jun 28, 2010 6:39 pm
Posts: 176
Delivery Date: 24 Jan 2012
Leaf Number: 17137
In my 2012, the mp3 tags do show correctly, but only on some of the songs. I've been doing some testing and troubleshooting. I have around 8GB worth of songs on a 16GB USB drive. When I checked on my computer into the properties on songs that displayed correctly vs. ones that didn't the significant item that seemed to be different was the "encoded by" field. Because of the lengthy time period (measured in years) of accumulating this library, this field could contain: iTunes n.n.n.n (where n.n.n.n is a version number), nothing at all, or possibly some other value. At first I thought only the ones with recent versions of iTunes listed in that field were the working ones, but now I'm not sure. It seems the simple act of modifying that field, and nothing else, from the Windows 7 file explorer, makes the tags readable by the Leaf. It doesn't seem to matter what you put in there, even putting nothing seems to work. I wonder if there is some slight unseen difference in how Windows 7 saves the tags vs. other applications within Windows or earlier versions of Windows like Windows XP.

In any case, I think I know how to get them all to read correctly now although the process may be quite time consuming.

_________________
Reserved: 04/20/10
Sold old EV: 09/25/11
Ordered: 09/28/11
Color locked in: 10/7/11
Delivery month appeared: 10/11/11
Delivery week appeared: 12/6/11
VIN received: 12/24/11
Delivered: 1/20/12

2012 Nissan Leaf SL
Brilliant Silver


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 75 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next

All times are UTC - 8 hours [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Advertise on the forum | Upgrade your account


© My Nissan Leaf Forum - part of the MyElectricCarForums.com Group