Ronnyandersson
Posts: 2
Joined: Mon Apr 16, 2018 10:12 pm
Delivery Date: 02 Apr 2018

Re: Leaf Spy Lite

Mon Apr 16, 2018 10:23 pm

I try getting started with a Bluetooth dongel and the LS lite. Two dongels have I tested, the first one did was a v2.1 and according to the app not supported for communication. The other one is an v1.5 (confirmed to support ALL communication by "ELM327 Identifier". But the LS lite still shows no stats. It seems to be stuck after config elm the config leaf shows. Number 14 appears and sometimes goes down to 12 or 10 I think.

Logg from lite setup:

2
true
true
false
0
false
false
31
10
5
0.5
false
true
360
0
-16777216
-1
-16776961
-1
-16777216
-65536
0
-16776961
-16737972
-3618816
-39424
-65281
-65536
false
false
false
false
8421
18
false
false
false
126
true
true
0
true
true
-92.5
0
false
false
300
false
false
0
2013
true
false
en
true
false

Ronnyandersson
Posts: 2
Joined: Mon Apr 16, 2018 10:12 pm
Delivery Date: 02 Apr 2018

Re: Leaf Spy Lite

Tue Apr 17, 2018 4:06 am

04/17/2018 9:06:06 00 000 NaN No Backup Data.txt file found!
04/17/2018 9:06:06 00 000 NaN Step 0 - BtAdmin already Initialized MacAdr = 00:1D:A5:68:98:8B
04/17/2018 9:06:06 00 000 NaN Step 1 - Using_WiFi=false Bluetooth=true WiFi=true
04/17/2018 9:06:06 13 000 NaN Step 3 - BtConnect: Trying to connect to BT device 00:1D:A5:68:98:8B 1 (Wait for interrupt)
04/17/2018 9:06:06 03 000 NaN Step 4 - 0.1 sec. Serial Port Opened Successfully & Service Started
04/17/2018 9:06:06 03 000 0 Step 5 - AStreamT Initialize to BTSerial
04/17/2018 9:06:12 05 014 0 Timer Tick cmd # 14
04/17/2018 9:06:17 05 014 0 Timer Tick cmd # 14
04/17/2018 9:06:22 05 014 0 Timer Tick cmd # 14
04/17/2018 9:06:28 05 014 0 Timer Tick cmd # 14

Turbo3
Gold Member
Posts: 1993
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy Lite

Tue Apr 17, 2018 1:02 pm

Ronnyandersson wrote:04/17/2018 9:06:06 00 000 NaN No Backup Data.txt file found!
04/17/2018 9:06:06 00 000 NaN Step 0 - BtAdmin already Initialized MacAdr = 00:1D:A5:68:98:8B
04/17/2018 9:06:06 00 000 NaN Step 1 - Using_WiFi=false Bluetooth=true WiFi=true
04/17/2018 9:06:06 13 000 NaN Step 3 - BtConnect: Trying to connect to BT device 00:1D:A5:68:98:8B 1 (Wait for interrupt)
04/17/2018 9:06:06 03 000 NaN Step 4 - 0.1 sec. Serial Port Opened Successfully & Service Started
04/17/2018 9:06:06 03 000 0 Step 5 - AStreamT Initialize to BTSerial
04/17/2018 9:06:12 05 014 0 Timer Tick cmd # 14
04/17/2018 9:06:17 05 014 0 Timer Tick cmd # 14
04/17/2018 9:06:22 05 014 0 Timer Tick cmd # 14
04/17/2018 9:06:28 05 014 0 Timer Tick cmd # 14

You need to take an ELM trace and send it to me. See bottom of help for details.

Be sure the Leaf is turned on or it will not respond. Dash gauges need to be active.

Most likely the adapter does not support the full ELM command set despite what version it reports. For the cheap ELM clones the version number is just made up. They like to use v2.1 even when they support less than v1.5.

The recommend OBDII adapter is the LELink.

Turbo3
Gold Member
Posts: 1993
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy Lite

Wed Apr 18, 2018 9:46 am

Trace received for this problem.

This problem is due to the OBDII adapter not working correctly. I have seen this before and is most likely detective firmware where this bug was never found during testing as the adapter was never tested on a Leaf. All OBDII adapters of this type will fail the same way timing out at state 14 which is the first Leaf specific command. The adapter will most likely work fine on other vehicles but is not going to work with the Leaf.

Recommend getting an LELink for Amazon or directly from the manufacturer who ships worldwide.

http://www.outdoor-apps.com/store1.html

lxvgto
Posts: 2
Joined: Fri Aug 24, 2018 3:37 pm
Delivery Date: 18 Aug 2018
Leaf Number: 326898
Location: PDX, OR

Re: Leaf Spy Lite

Fri Aug 31, 2018 8:29 am

Hello, Newb here, have just ordered the recommended LELink obd2 adaptor from https://www.amazon.com/gp/product/B0755N61PW/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1, thanks for posting this recommendation (somewhere, i've been reading so many postings, i can't remember where!).
Now I have gone to get Leaf Spy Lite as recommended by Turbo3 (https://www.amazon.com/Turbo3-Leaf-Spy-Pro/dp/B00PMLTPN0/ref=sr_1_cc_1?s=aps&ie=UTF8&qid=1535728571&sr=1-1-catcorr&keywords=leaf+spy) for my Iphone SE.
Unfortunately I cannot find this in the App Store nor on Amazon from my phone.
Did i miss something - is Leaf Spy Lite NOT available for iOS, yet Leaf Spy Pro IS available for iOS?

thanks!
2018-08-19 / Used pearl white 2015 LEAF S / Mfd 2015-02 / In-service 2015-07-28

onemorerick
Posts: 1
Joined: Thu Dec 13, 2018 8:28 am
Delivery Date: 17 Nov 2018
Leaf Number: 324861

Re: Leaf Spy Lite

Thu Dec 13, 2018 9:25 am

I believe that I have a slightly different behavior from Leaf Spy Lite (v0.34.27) than has been described here previously. Car model year is 2015.
ODBII device is ELM 327 Mini. Pairs with Galaxy SIII phone. The lower right hand corner of the app display cycles between the (yellow) Retry in xx Seconds and (green) Connected 1 through 31. After reaching Connected 31 the cycle begins again. The chart displays 119 QCs & 724
L1/L2s on top and 12.40V in the lower left, and the rest of the data values are 0. The information at the bottom middle which displays the software version also has a line below the version which is obscured by the date which overlays that line so I cannot see the firmware version of the ODBII device, though I suspect in may be not be 1.5 as recommended elsewhere in this thread. I tried selecting all the app system settings as well as enabling the slow transfer mode but the behavior does not change. The app does not display anything about missing commands. I can send the device to you if that is useful.

sonachan1
Posts: 2
Joined: Sat Feb 23, 2019 12:39 pm
Delivery Date: 23 Feb 2019

Re: Leaf Spy Lite

Sun Feb 24, 2019 8:45 am

Hey guys,

I'm using Leaf Spy Lite (v0.34.27 en) on a Motorola G6 running Android 8. I've got a LELink dongle which seems to be connecting OK, but can't get much further forwards as I'm only connected to a Leaf Battery Pack. That's with a '2016 Leaf' selected in settings.

When I select BMS from the list (I don't have an option for 'motor'), the app crashes immediately. There doesn't seem to be anything immediately obvious in the error logs.

Anything I can check or am I missing something?

bjn
Posts: 6
Joined: Sun Mar 29, 2015 4:46 pm
Delivery Date: 29 Mar 2015
Location: Sweden

Re: Leaf Spy Lite

Mon Feb 25, 2019 2:02 am

sonachan1 wrote:Hey guys,

I'm using Leaf Spy Lite (v0.34.27 en) on a Motorola G6 running Android 8. I've got a LELink dongle which seems to be connecting OK, but can't get much further forwards as I'm only connected to a Leaf Battery Pack. That's with a '2016 Leaf' selected in settings.

When I select BMS from the list (I don't have an option for 'motor'), the app crashes immediately. There doesn't seem to be anything immediately obvious in the error logs.

Anything I can check or am I missing something?


I had the same issue yesterday. I tried it on two android devices. So I think the latest version must have this issue. The BMS year model has worked for me before.

(But one thing I'm wondering about is how it works standalone. Because my ELM327 is one of those chinese copy's, which presents itself as version 1.5. And as far as I know, it doesn't send "ACKs" on CAN messages. It's only silently listening. This works in a car environment where any other ECU will send ACKs. But with the BMS standalone, "someone" on the bus needs to send ACKs on the messages sent by the BMS, and it isn't the ELM? At least I assume that, otherwise the bus will just be flooded with retransmissions.)

bjn
Posts: 6
Joined: Sun Mar 29, 2015 4:46 pm
Delivery Date: 29 Mar 2015
Location: Sweden

Re: Leaf Spy Lite

Mon Feb 25, 2019 4:19 am

In the absence of Turbo3, can somebody tell me if the payed versions of Leaf spy for android has the same issue? or does setting the BMS year model option cause a crash on those too?

Also, is it possible to get hold of an old build of Leafspy, where this option worked?

Turbo3
Gold Member
Posts: 1993
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy Lite

Mon Feb 25, 2019 10:28 pm

bjn wrote:In the absence of Turbo3, can somebody tell me if the payed versions of Leaf spy for android has the same issue? or does setting the BMS year model option cause a crash on those too?

Also, is it possible to get hold of an old build of Leafspy, where this option worked?

The BMS selection bug was fixed in the pay versions and is fixed in the Lite test version 0.34.29 that I just uploaded to Google.

You can access the fixed test version using the below link although it might take Google a few hours to update the link from the 0.34.28 code to 0.34.29 code.

https://play.google.com/apps/testing/com.Turbo3.Leaf_Spy_Lite

If this test version works for everyone I will release it to production in a couple of days.

This version like 0.34.28 supports Androids new way of handling permission by asking for them at run time after first installing an app. If the app was already installed permissions are already set so no messages are needed.

However, the messages Android presents are very broad. The "Phone" permission I need to read phone status results in a warning message that makes it sound like LeafSpy is asking "to make and manage phone calls". Which is absolutely false.

Return to “LEAF CANBus”