TheJeebas
Posts: 11
Joined: Wed Nov 02, 2016 5:47 pm
Delivery Date: 02 Nov 2016

Stereo / Speakers Issue

Fri Sep 22, 2017 11:53 am

I bought a 2015 S last November and probably around a month later I noticed that the stereo starts crackling around 17-20 level. Now if I am listening to ambient, string music or something this doesn't matter, but anything with percussion it just crackles. I am considering trying to troubleshoot it myself but am not really sure if it's the speakers, amplifier(s?) or the unit itself.

When it was in at the Nissan dealership for the airbag recall I had them try to duplicate it, but they couldn't, (and I couldn't there either, but it was a loud shop environment) so it seems like it only happens when the car is moving. I understand that the base OEM stereos in LEAFS are garbage but I don't think that 20 (it maxes at 35-40) is reasonable for the output to crackle and pop at.

#1 I try to fix it myself and spend more time than I have to spend and possibly break things.
#2 I take it back to the Nissan dealership and ask them to fix it
#3 I take it to a third party car stereo place and ask them to fix it
#4 I eat a few thousand bucks and get another used SV or SL Leaf (with QC and LED, thinking about doing this anyways for better charging time and better headlights)

Obviously me fixing it myself is the cheapest option but I could end up breaking some things.

Has anyone else experienced this?

Thanks

LeftieBiker
Posts: 7369
Joined: Wed May 22, 2013 3:17 am
Delivery Date: 31 May 2013
Location: Upstate New York, US

Re: Stereo / Speakers Issue

Fri Sep 22, 2017 1:34 pm

That sounds to me like a slightly damaged speaker. See if it is coming from one or both (all four?) speakers. If it's all of them then either a previous owner blew them out or it's an issue with the stereo.
2013 "Brilliant Silver" SV with Premium Package and no QC, and 2009 Vectrix VX-1 with 18 Leaf cells.

The most offensive, tasteless phrase in use here is "Pulled the trigger." I no longer respond to posts that use it.

TheJeebas
Posts: 11
Joined: Wed Nov 02, 2016 5:47 pm
Delivery Date: 02 Nov 2016

Re: Stereo / Speakers Issue

Fri Sep 29, 2017 10:36 am

Thanks for the advice!

I tried isolating the speakers and it seems to be all of them.

I am going to (carefully) try to remove and swap mine and my wife's and see if that fixes it, and if so I will pick up a replacement stereo head on eBay. Otherwise I guess I am looking at four new speakers... Still cheaper than selling this one and buying another used LEAF

powersurge
Posts: 766
Joined: Wed Oct 21, 2015 10:24 am
Delivery Date: 06 Dec 2014
Location: Long Island, NY

Re: Stereo / Speakers Issue

Tue Oct 03, 2017 9:30 am

If you are not the original owner, then you probably have speakers that were over stressed.. I really don't think that the stock S stereo is that bad... I have it, and the sound is very decent. I also have a Mazda Miata with the BOSE system, and don't hear any great difference.

As said by the previous poster, I would suggest you replace the speakers with ones that "you would really like" in the car. If you don't know what you are doing, then don't try to take the panels off, because you will cause damage. Pay a stereo place, and I am sure that the installation of speakers will be minimal.

I you are not happy after the new speakers, THEN start thinking about a new stereo. By no means should you sell a car to change the stereo!!

Return to “Music / Navigation / Handsfree”